user-packages.nix 2.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Nix environment user configuration for the MMGen Project
  2. #
  3. # In addition to setting new attributes, this file may be used to override the defaults
  4. # in nix/packages.nix of the mmgen-wallet repository
  5. { pkgs, python, bdir }:
  6. rec {
  7. ### Set nixpkgs globally for the MMGen environment.
  8. ### If you set it, make sure to uncomment the python variable assignment below.
  9. # pkgs = import (bdir + /nixpkgs-24.05.nix) {};
  10. ### Set python version globally for the MMGen environment.
  11. ### Must be set if pkgs is set.
  12. # python = pkgs.python312;
  13. system-packages = with pkgs; {
  14. # monero-cli = monero-cli; # Monero daemon
  15. # # go-ethereum = go-ethereum; # Geth - latest version for transacting on mainnet
  16. # go-ethereum = callPackage (bdir + /go-ethereum.nix) { # Geth - old version for test suite (ethdev)
  17. # buildGoModule = buildGo122Module;
  18. # tag_version = "v1.13.15";
  19. # vendor_hash = "sha256-LWNFuF66KudxrpWBBXjMbrWP5CwEuPE2h3kGfILIII0";
  20. # };
  21. # litecoin = callPackage (bdir + /litecoin.nix) {}; # Litecoin daemon
  22. # bitcoin-cash = callPackage (bdir + /bitcoin-cash-node.nix) {}; # Bitcoin Cash Node daemon
  23. # zcash-mini = callPackage (bdir + /zcash-mini.nix) {}; # ZEC (test suite)
  24. ### For development with --pure (add/remove packages for your setup):
  25. # neovim-qt = neovim-qt;
  26. # rxvt-unicode = rxvt-unicode;
  27. # which = which;
  28. # ctags = ctags;
  29. # xclip = xclip;
  30. ### For test suite with --pure:
  31. # openssh = openssh; # XMR tests
  32. };
  33. python-packages = with python.pkgs; {
  34. # pycryptodome = pycryptodome; # altcoins
  35. # py-ecc = py-ecc; # ETH, ETC
  36. # mypy-extensions = mypy-extensions; # ETH, ETC
  37. # pysocks = pysocks; # XMR
  38. # monero = monero; # XMR (test suite)
  39. # eth-keys = eth-keys; # ETH, ETC (test suite)
  40. };
  41. }