packages.nix 1.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. { pkgs, python }:
  2. {
  3. system-packages = with pkgs; {
  4. bitcoind = bitcoind; # Bitcoin Core daemon
  5. vanitygen = (callPackage ./vanitygen-plusplus.nix {}); # test suite
  6. curl = curl;
  7. git = git;
  8. gcc = gcc;
  9. libtool = libtool;
  10. autoconf = autoconf;
  11. gmp = gmp;
  12. gmp4 = gmp4;
  13. openssl = openssl;
  14. pcre = pcre;
  15. mpfr = mpfr;
  16. secp256k1 = secp256k1.overrideAttrs {
  17. pname = "secp256k1-v0.6.0";
  18. src = fetchGit {
  19. url = "https://github.com/bitcoin-core/secp256k1.git";
  20. ref = "refs/tags/v0.6.0";
  21. };
  22. };
  23. less = less; # test suite (cmdtest.py regtest)
  24. procps = procps; # test suite (pgrep)
  25. ruff = ruff;
  26. ## For test suite with --pure:
  27. e2fsprogs = e2fsprogs;
  28. util-linux = util-linux; # losetup
  29. ncurses = ncurses; # infocmp
  30. };
  31. python-packages = with python.pkgs; {
  32. pip = pip;
  33. setuptools = setuptools;
  34. build = build;
  35. wheel = wheel;
  36. gmpy2 = gmpy2;
  37. cryptography = cryptography;
  38. pynacl = pynacl;
  39. ecdsa = ecdsa;
  40. aiohttp = aiohttp;
  41. requests = requests;
  42. py-scrypt = py-scrypt;
  43. semantic-version = semantic-version;
  44. pexpect = pexpect; # test suite
  45. pycoin = pycoin; # test suite
  46. };
  47. }