123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051 |
- {
- pkgs,
- lib,
- stdenv,
- buildGoModule,
-
- tag_version,
- vendor_hash,
- }:
- buildGoModule {
- pname = "go-ethereum";
- version = tag_version;
- src = fetchGit {
- url = "https://github.com/ethereum/go-ethereum.git";
- ref = "refs/tags/${tag_version}";
- };
- proxyVendor = false;
- vendorHash = vendor_hash;
- doCheck = false;
- subPackages = [ "cmd/geth" ];
-
- tags = [ "urfave_cli_no_docs" ];
-
- propagatedBuildInputs = lib.optionals stdenv.hostPlatform.isDarwin [
- pkgs.libobjc
- pkgs.IOKit
- ];
-
- meta = with lib; {
- homepage = "https://geth.ethereum.org/";
- description = "Official golang implementation of the Ethereum protocol";
- license = with licenses; [
- lgpl3Plus
- gpl3Plus
- ];
- maintainers = with maintainers; [ RaghavSood ];
- mainProgram = "geth";
- };
- }
|