user-packages.nix 2.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Nix environment user configuration for the MMGen Project
  2. #
  3. # In addition to setting new attributes, this file may be used to override the defaults
  4. # in nix/packages.nix of the mmgen-wallet repository
  5. { pkgs, python, bdir }:
  6. rec {
  7. ### Set nixpkgs globally for the MMGen environment.
  8. ### If you set it, make sure to uncomment the python variable assignment below.
  9. # pkgs = import (bdir + /nixpkgs-24.11.nix) {};
  10. ### Set python version globally for the MMGen environment.
  11. ### Must be set if pkgs is set.
  12. # python = pkgs.python312;
  13. system-packages = with pkgs; {
  14. # monero-cli = monero-cli; # Monero daemon
  15. # # go-ethereum = go-ethereum; # Geth - latest version for transacting on mainnet
  16. # go-ethereum = callPackage (bdir + /go-ethereum.nix) { # Geth - old version for test suite (ethdev)
  17. # buildGoModule = buildGo122Module;
  18. # tag_version = "v1.13.15";
  19. # vendor_hash = "sha256-LWNFuF66KudxrpWBBXjMbrWP5CwEuPE2h3kGfILIII0";
  20. # };
  21. # solc = callPackage (bdir + /solc.nix) {}; # Solidity compiler
  22. # litecoin = callPackage (bdir + /litecoin.nix) {}; # Litecoin daemon
  23. # bitcoin-cash = callPackage (bdir + /bitcoin-cash-node.nix) {}; # Bitcoin Cash Node daemon
  24. # zcash-mini = callPackage (bdir + /zcash-mini.nix) {}; # ZEC (test suite)
  25. ### For development with --pure (add/remove packages for your setup):
  26. # neovim-qt = neovim-qt;
  27. # rxvt-unicode = rxvt-unicode;
  28. # which = which;
  29. # ctags = ctags;
  30. # xclip = xclip;
  31. ### For test suite with --pure:
  32. # openssh = openssh; # XMR tests
  33. };
  34. python-packages = with python.pkgs; {
  35. # pycryptodome = pycryptodome; # altcoins
  36. # py-ecc = py-ecc; # ETH, ETC
  37. # mypy-extensions = mypy-extensions; # ETH, ETC
  38. # pysocks = pysocks; # XMR
  39. # monero = monero; # XMR (test suite)
  40. # eth-keys = eth-keys; # ETH, ETC (test suite)
  41. };
  42. }