1234567891011121314151617181920212223242526272829303132333435363738394041424344 |
- {
- lib,
- pkgs,
- fetchFromGitHub,
- }:
- with pkgs.python312.pkgs;
- buildPythonPackage rec {
- pname = "yahooquery";
- version = "2.3.7";
- pyproject = true;
- disabled = pythonOlder "3.8.1";
- src = fetchFromGitHub {
- owner = "dpguthrie";
- repo = "yahooquery";
- rev = "refs/tags/v${version}";
- hash = "sha256-Iyuni1SoTB6f7nNFhN5A8Gnv9kV78frjpqvvW8qd+/M=";
- };
- patches = [ ./yahooquery-noversioning.patch ];
- build-system = [ poetry-core ];
- dependencies = [
- requests
- pandas
- requests-futures
- tqdm
- lxml
- selenium
- beautifulsoup4
- ];
- doCheck = false;
- meta = with lib; {
- description = "Python wrapper for an unofficial Yahoo Finance API";
- homepage = "https://yahooquery.dpguthrie.com";
- license = licenses.mit;
- };
- }
|