yahooquery.nix 1022 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. {
  2. lib,
  3. pkgs,
  4. fetchFromGitHub,
  5. }:
  6. with pkgs.python312.pkgs;
  7. buildPythonPackage rec {
  8. pname = "yahooquery";
  9. version = "2.3.7";
  10. pyproject = true;
  11. disabled = pythonOlder "3.8.1";
  12. src = fetchFromGitHub {
  13. owner = "dpguthrie";
  14. repo = "yahooquery";
  15. rev = "refs/tags/v${version}";
  16. hash = "sha256-Iyuni1SoTB6f7nNFhN5A8Gnv9kV78frjpqvvW8qd+/M=";
  17. };
  18. patches = [ ./yahooquery-noversioning.patch ];
  19. build-system = [ poetry-core ];
  20. dependencies = [
  21. requests # ^2.31.0
  22. pandas # ^2.0.3
  23. requests-futures # ^1.0.1
  24. tqdm # ^4.65.0
  25. lxml # ^4.9.3
  26. selenium # {version = ^4.10.0, optional = true}
  27. beautifulsoup4 # ^4.12.2
  28. ];
  29. doCheck = false; # skip tests
  30. meta = with lib; {
  31. description = "Python wrapper for an unofficial Yahoo Finance API";
  32. homepage = "https://yahooquery.dpguthrie.com";
  33. license = licenses.mit;
  34. };
  35. }